https://plex.tv issues
Incident Report for Plex
Resolved
Rolled back new features
Posted about 2 years ago. Dec 03, 2015 - 16:06 PST
Investigating
Site is down, researching plex.tv issues
Posted about 2 years ago. Dec 03, 2015 - 15:32 PST