Forums Are Currently Down
Incident Report for Plex
Resolved
Our forums service provider has resolved the availability issues.
Posted over 2 years ago. Aug 06, 2015 - 09:16 PDT
Identified
Reoccurred networking issue with forums service provider.
Posted over 2 years ago. Aug 06, 2015 - 06:04 PDT