Effects of Amazon S3 availability issues
Incident Report for Plex
Resolved
Amazon has now resolved their S3 service availability issues and services should now be back to normal.
Posted 8 months ago. Feb 28, 2017 - 14:44 PST
Monitoring
Amazon S3 (US-EAST-1) is currently experiencing availability issues, which impact services hosted there. For Plex, this includes our partner which provides trailers and extras that are automatically gathered for Plex Pass subscribers and some functionality with the community forums (uploads as well as some downloads and CDN content). It's possible some metadata providers may be affected by the Amazon S3 issue, too. See the following for some more details:

https://status.aws.amazon.com/
http://status.vanillaforums.com/
Posted 8 months ago. Feb 28, 2017 - 11:03 PST