Intermittent issues loading Plex Web App
Incident Report for Plex
Resolved
The issue has been resolved. If you still encounter a 503 error, you may need to clear your DNS cache (or perhaps try switching to use something like "Google Public DNS" or "OpenDNS").
Posted 3 months ago. Aug 23, 2017 - 23:18 PDT
Investigating
We're currently seeing some intermittent issues being encountered by some users when loading our hosted Plex Web App (https://app.plex.tv/desktop). This may result in a 503 error for users. We're investigating the cause.
Posted 3 months ago. Aug 23, 2017 - 22:55 PDT