Unexpected maintenance
Incident Report for Plex
Resolved
Maintenance has concluded and services are available again. Thanks for your patience!
Posted about 1 year ago. Dec 06, 2016 - 10:37 PST
Identified
We have to perform some unscheduled maintenance to resolve database load issues affecting users. We hope to have things resolved and restored very shortly.
Posted about 1 year ago. Dec 06, 2016 - 10:16 PST