New website deploy
Incident Report for Plex
Resolved
The new website is live and account access issues are resolved. We'll continue to fine-tune things. Enjoy your Plexing!
Posted about 1 year ago. Jun 23, 2016 - 22:28 PDT
Update
For now, you can visit https://app.plex.tv/web/app directly to sign in to an account and access Plex Web App.
Posted about 1 year ago. Jun 23, 2016 - 21:25 PDT
Monitoring
We're currently deploying a new website and bringing all services online. There may be some temporary account-related or other service issues during the transition.
Posted about 1 year ago. Jun 23, 2016 - 20:53 PDT