Maintenance scheduled for Feb 11, 22:00 PST (Feb 12, 06:00 GMT)
Incident Report for Plex
Resolved
https://plex.tv has been stable. If you are still getting a maintenance page, please flush your DNS as we implemented a DNS change. If you do not know how to flush your DNS, reboot your device.
Posted over 1 year ago. Feb 12, 2016 - 00:26 PST
Update
Working out some kinks still but in general the site https://plex.tv is back up again.
Posted over 1 year ago. Feb 11, 2016 - 23:26 PST
Monitoring
Starting 22:00 PST, Feb 11 (06:00 GMT, Feb 12), we will be performing maintenance while we migrate some critical components. We anticipate the maintenance to last no more than 2 hours (and will likely complete much sooner), during which the https://plex.tv/ site and services will be unavailable, including login/authentication services.
Posted over 1 year ago. Feb 11, 2016 - 08:20 PST