Unexpected Service Interruption
Incident Report for Plex
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 09, 2017 - 20:29 PDT
Monitoring
We've restored services and are continuing to monitor and investigate.
Posted 4 months ago. Jul 09, 2017 - 12:34 PDT
Investigating
We're experiencing unexpected issues with some backend services, including login/authentication. We're already investigating.
Posted 4 months ago. Jul 09, 2017 - 12:09 PDT