www.plex.tv unexpected interruption
Incident Report for Plex
Resolved
Site came back again 15 minutes ago and we'll continue to monitor and investigate why this happened
Posted 11 months ago. Jul 11, 2017 - 13:51 PDT
Identified
Marketing website down due to server corruption. Restoring from backup. Plex Media Server application servers are functional
Posted 11 months ago. Jul 11, 2017 - 12:56 PDT