Unexpected downtime 2017-09-29
Incident Report for Plex
Resolved
The issue has been resolved
Posted 18 days ago. Sep 29, 2017 - 09:48 PDT
Investigating
We're experiencing unexpected downtime with some of our back end services. This can result in an inability to access the Plex site or use account-related and other services. We're investigating to resolve things as quickly as possible.
Posted 18 days ago. Sep 29, 2017 - 07:55 PDT