Forums Are Currently Down
Incident Report for Plex
Resolved
Forums provider has fixed the problem and monitoring systems
Posted almost 2 years ago. Aug 05, 2015 - 18:06 PDT
Monitoring
Forums looks to be back up. Checking with service provider to see if it's permanently fixed or not
Posted almost 2 years ago. Aug 05, 2015 - 18:02 PDT
Identified
Networking issue with forums service provider.
Posted almost 2 years ago. Aug 05, 2015 - 17:35 PDT