Unplanned maintenace - CSS formatting on some pages
Incident Report for Plex
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 12, 2016 - 13:09 PST
Investigating
Unplanned maintenance. CSS formatting issue which could cause some links to be unavailable ( possible 404s as well ). Expected to be fixed soon
Posted 7 months ago. Dec 12, 2016 - 12:22 PST