'Invalid Merchant ID' errors for subscription transactions
Incident Report for Plex
Resolved
Our payment processor has informed us that the issue has now been resolved.
Posted almost 2 years ago. Jul 10, 2015 - 15:23 PDT
Monitoring
Our payment processor, Braintree, is currently experiencing some issues that can cause 'Invalid Merchant ID' errors for users trying to sign up for a Plex Pass subscription, change their billing information, or process a regular subscription renewal. We're working with them to resolve these issues as quickly as possible and we'll update when we have more information to share.
Posted almost 2 years ago. Jul 09, 2015 - 14:58 PDT