Resolved
The implemented fix is working as expected.
Monitoring
A fix has been deployed and music matching should be working as expected. We will continue to monitor.
Investigating
We are investigating an issue of failed music matches for Plex Media Server users.