Report a problem
Powered by
Privacy policy
·
Terms of service
Music metadata performance issue
Resolved
·
Degraded performance
This incident has been resolved.
Fri, Nov 7, 2025, 08:37 AM
(
5
months ago)
·
View all updates
Affected components
Nov 7, 2025, 02:23 AM
08:37 AM
Media Metadata
1 affected component
Updates
Resolved
This incident has been resolved.
Fri, Nov 7, 2025, 08:37 AM
Investigating
We are currently investigating this issue.
Fri, Nov 7, 2025, 02:23 AM
(
6
hours earlier)
Music metadata performance issue - Plex Status