·
This incident has been resolved.
Resolved
Monitoring
We are currently monitoring the service.
Investigating
We have received reports of slow response times from our Video On Demand service. We are currently investigating.