Movies & Shows free streaming
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 00:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2024 - 21:01 UTC
Investigating
We are currently investigating this issue.
Posted Apr 16, 2024 - 20:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2024 - 19:41 UTC
Investigating
We are currently investigating this issue.
Posted Apr 16, 2024 - 19:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2024 - 19:12 UTC
Investigating
We're currently investigating issues affecting our free Movies & Shows streaming. You may experience slow responses or failures accessing this free streaming during this time. This does not impact access to personal media.
Posted Apr 16, 2024 - 18:28 UTC
This incident affected: Video On Demand (AVOD - US, AVOD - Europe).