Video On Demand
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Aug 11, 2021 - 18:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2021 - 15:43 UTC
Investigating
To our Plex users experiencing issues with Free Movies & Shows on Plex, we're already on it! As we investigate the issue, you may encounter slow responses or have trouble streaming our library of free entertainment, and we appreciate your patience. There should be no impact your access to personal media as we work to resolve the issue. Thanks, your Plex team.
Posted Aug 11, 2021 - 15:24 UTC
This incident affected: Video On Demand (AVOD - US, AVOD - Europe).