Music via TIDAL
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Apr 08, 2021 - 13:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2021 - 12:49 UTC
Investigating
To our Plex users experiencing issues with your TIDAL Music in Europe, we're already on it! As we investigate the issue, you may encounter slow responses or have trouble accessing music via TIDAL, and we appreciate your patience. There should be no impact your access to personal media as we work to resolve the issue. Thanks, your Plex team.
Posted Apr 08, 2021 - 12:19 UTC
This incident affected: Music via TIDAL (Music via TIDAL - Europe).