Plex.tv Maintenance at 00:00 PST Feb 16, 2015 and should last less than 30 minutes.
Incident Report for Plex
Resolved
Performance update completed
Posted Feb 16, 2015 - 08:12 UTC
Identified
Performing some application performance improvements requiring some downtime during the upgrade. Maintenance page will be enabled at 00:00 PST Feb 16, 2015
Posted Feb 16, 2015 - 07:44 UTC