Login issues from plex.tv website
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Jul 26, 2021 - 22:15 UTC
Monitoring
A fix has been implemented. If you are still experiencing issues, please try to hard refresh the website and try again.
Posted Jul 26, 2021 - 21:56 UTC
Investigating
We are currently investigating an issue where account sign-in isn't working correctly from our website. In the meantime, please use https://app.plex.tv to login.
Posted Jul 26, 2021 - 20:46 UTC
This incident affected: Plex website (www.plex.tv).