Plex website not reachable
Incident Report for
Plex
Resolved
This incident has been resolved.
Posted
Aug
24
,
2022
-
14:02
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Aug
24
,
2022
-
11:09
UTC
Identified
The issue has been identified and a fix is being implemented.
Posted
Aug
24
,
2022
-
10:56
UTC
Investigating
We are investigating a problem impacting our
www.plex.tv
site
Posted
Aug
24
,
2022
-
09:42
UTC
This incident affected: Plex website (www.plex.tv).
×
Subscribe to Incident
Subscribe to updates for
Plex website not reachable
via . You'll receive .