Site and login services
Incident Report for Plex
Resolved
The issue has been resolved. The site and login services are back to normal.
Posted Jun 25, 2015 - 17:25 UTC
Investigating
We're experiencing some http://plex.tv site issues, which may affect app sign-ins, too. We're investigating.
Posted Jun 25, 2015 - 17:18 UTC