Plex

Powered by
Privacy policy

·

Terms of service
Music metadata search performance impact
Resolved·Degraded performance

This incident has been resolved.

Fri, Jun 20, 2025, 06:50 AM
(9 months ago)
·
Affected components
Jun 19, 2025, 04:12 AM
04:24 AM
Updates

Resolved

This incident has been resolved.

Fri, Jun 20, 2025, 06:50 AM

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Jun 19, 2025, 04:24 AM(1 day earlier)

Investigating

We are investigating an issue on our music metadata search service in Europe that can impact performance

Thu, Jun 19, 2025, 04:12 AM(11 minutes earlier)