Verification is currently underway for the maintenance items.
Posted Oct 22, 2025 - 09:56 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 08:30 UTC
Scheduled
We are planning a maintenance on the plex.tv API backends. No downtime is expected but we expect higher latency and some failed requests while the maintenance is ongoing.
Posted Oct 21, 2025 - 09:51 UTC
This scheduled maintenance affected: Authentication and API server (plex.tv).