AVOD content delivery network service interruption
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 00:43 UTC
Identified
The content delivery network for our "Movies & TV" streaming is currently experiencing a service interruption, which is affecting the ability to play content from the "Movies & TV" service.
Posted Mar 25, 2020 - 23:02 UTC
This incident affected: Video On Demand (AVOD - US, AVOD - Europe).