Slow responses from plex.direct DNS servers
Incident Report for Plex
Resolved
This incident has been resolved. DNS lookups for plex.direct queries are responding correctly.
Posted Aug 18, 2020 - 22:38 UTC
Investigating
We are currently investigating issues with slow lookup responses on our plex.direct DNS servers.
Posted Aug 18, 2020 - 19:40 UTC
This incident affected: Remote Access (plex.direct DNS servers).