Issues with plex.direct DNS resolution
Incident Report for Plex
Resolved
This incident has been resolved.

Our plex.direct DNS servers were receiving an extraordinarily high amount of requests and were unable to keep up. We have made changes on our firewalls to properly handle the volume of requests.
Posted Jul 19, 2021 - 00:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2021 - 23:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2021 - 23:28 UTC
Update
We are still continuing to investigate this issue.
Posted Jul 18, 2021 - 22:33 UTC
Update
We are still continuing to investigate this issue.
Posted Jul 18, 2021 - 20:55 UTC
Update
We are still continuing to investigate this issue.
Posted Jul 18, 2021 - 18:42 UTC
Update
We are continuing to investigate this issue.
Posted Jul 18, 2021 - 17:20 UTC
Investigating
We are experiencing a high error rate on our plex.direct DNS servers. We are currently investigating the issue.
Posted Jul 18, 2021 - 15:55 UTC
This incident affected: Remote Access (plex.direct DNS servers).