Video On Demand
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Mar 11, 2021 - 18:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2021 - 18:25 UTC
Update
We are continuing to investigate this issue.
Posted Mar 11, 2021 - 18:09 UTC
Update
We are continuing to investigate this issue.
Posted Mar 11, 2021 - 18:07 UTC
Investigating
To our Plex users experiencing issues with Free Movies & Shows on Plex, we're already on it! As we investigate the issue, you may encounter slow responses or have trouble streaming our library of free entertainment, and we appreciate your patience. There should be no impact your access to personal media as we work to resolve the issue. Thanks, your Plex team.
Posted Mar 11, 2021 - 18:06 UTC
This incident affected: Music via TIDAL (Music via TIDAL - US), Video On Demand (AVOD - US), Live TV and TV Program Guide Data (Live TV and TV Program Guide Data - US), and Web Shows (Web Shows - US).