Service degradation identified for some of our US services

Incident Report for Plex

Resolved

This incident has been resolved.
Posted May 28, 2025 - 23:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 00:12 UTC

Investigating

We are investigating a networking issue with some of our US services. Response times may be slower than usual and may time out.
Posted May 27, 2025 - 21:54 UTC
This incident affected: Live TV and TV Program Guide Data (Live TV and TV Program Guide Data - US), Video On Demand (AVOD - US), and Media Metadata (metadata.provider.plex.tv - US).