Plex

Powered by
Privacy policy

·

Terms of service
Movies & Shows free streaming
Resolved·Degraded performance

This incident has been resolved.

Tue, Mar 19, 2024, 10:33 AM
(2 years ago)
·
Affected components
Mar 19, 2024, 09:15 AM
09:54 AM
Updates

Resolved

This incident has been resolved.

Tue, Mar 19, 2024, 10:33 AM

Monitoring

We are continuing to monitor for any further issues.

Tue, Mar 19, 2024, 09:54 AM(39 minutes earlier)

Monitoring

A fix has been implemented and we are monitoring the results.

Tue, Mar 19, 2024, 09:53 AM

Identified

The issue has been identified and has been caused by a maintenance on our of our backend

Tue, Mar 19, 2024, 09:31 AM(22 minutes earlier)

Investigating

We are continuing to investigate this issue.

Tue, Mar 19, 2024, 09:25 AM

Investigating

We're currently investigating issues affecting our free Movies & Shows streaming. You may experience slow responses or failures accessing this free streaming during this time. This does not impact access to personal media.

Tue, Mar 19, 2024, 09:15 AM