Movies & Shows free streaming
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 16:17 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 18, 2023 - 15:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2023 - 15:15 UTC
Identified
We have identified an issue with our upstream provider. We will provide updates as soon as they become available.
Posted Dec 18, 2023 - 14:28 UTC
Investigating
We're currently investigating issues affecting our free Movies & Shows streaming. You may experience slow responses or failures accessing this free streaming during this time. This does not impact access to personal media.
Posted Dec 18, 2023 - 14:27 UTC
This incident affected: Video On Demand (AVOD - US, AVOD - Europe).