Outage impacting watch.plex.tv
Incident Report for
Plex
Resolved
We think the impact from the issue is over.
Posted
Aug
07
,
2024
-
21:22
UTC
Identified
An upstream provider is experiencing issues resulting in an outage of
https://watch.plex.tv
. We're actively monitoring the situation and will provide an update when we know more.
Posted
Aug
07
,
2024
-
19:24
UTC
×
Subscribe to Incident
Subscribe to updates for
Outage impacting watch.plex.tv
via . You'll receive .