Slow response times from plex.tv API
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Nov 29, 2020 - 04:36 UTC
Investigating
We are currently investigating slow response times from our API.
Posted Nov 29, 2020 - 03:55 UTC
This incident affected: plex.tv - Authentication and API server.