Movies & Shows free streaming
Incident Report for Plex
Resolved
This incident has been resolved.
Posted May 20, 2022 - 13:28 UTC
Investigating
We're currently investigating issues affecting our free Movies & Shows streaming. You may experience slow responses or failures accessing this free streaming during this time. This does not impact access to personal media.
Posted May 20, 2022 - 13:06 UTC
This incident affected: Video On Demand (AVOD - US, AVOD - Europe).