watch.plex.tv errors
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 07:40 UTC
Monitoring
We've deployed a a fix and are monitoring closely the results.
Posted Dec 12, 2023 - 04:30 UTC
Identified
We have identified an issue with our upstream provider. We will provide updates as soon as they become available.
Posted Dec 12, 2023 - 03:43 UTC
Investigating
We are currently investigating this issue.
Posted Dec 12, 2023 - 03:40 UTC
This incident affected: watch.plex.tv.