plex.tv website unavailable
Incident Report for Plex
Resolved
This incident has been resolved.
Posted May 09, 2023 - 20:13 UTC
Update
We are continuing to monitor for any further issues.
Posted May 09, 2023 - 19:41 UTC
Update
We are continuing to monitor for any further issues.
Posted May 09, 2023 - 19:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2023 - 19:31 UTC
Identified
An issue has been identified with our backend service provider.
Posted May 09, 2023 - 18:57 UTC
Investigating
We are investigating reports of degraded performance for www.plex.tv.
Posted May 09, 2023 - 18:52 UTC
This incident affected: Plex website (www.plex.tv).