Email delays for plex.tv account activity
Incident Report for Plex
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 18:46 UTC
Identified
An issue has been identified with our email vendor (Sendgrid) which is delaying/preventing the sending of emails related to plex.tv account activity. This includes emails for recover password, new device logins, etc.

Sendgrid is aware of this issue and is working to resolve it. You can view their status updates here: https://status.sendgrid.com/incidents/c2k6nqpr9t7p
Posted Jul 28, 2020 - 16:40 UTC
This incident affected: plex.tv - Authentication and API server.