Discover Together Service distruption
Incident Report for Plex
Resolved
We've added additional scale to our backend services to improve the health of the service and have a seen a healthy return to our expected latency patterns.
Posted Nov 01, 2023 - 19:12 UTC
Identified
We're seeing latency spikes in our new Discover Together launch. We've identified the root issue and we're currently rolling out a fix.
Posted Nov 01, 2023 - 18:05 UTC